Platform Explorer / Nuxeo Platform LTS 2015 7.10

Component org.nuxeo.ecm.automation.server.auth.config

Services

Extension points

Contributions

XML source

<?xml version="1.0"?>
<component name="org.nuxeo.ecm.automation.server.auth.config">
<!--
Setup a Basic Auth plugin for /automation paths that will always send 401 on authentication failures
-->

  <require>org.nuxeo.ecm.platform.ui.web.auth.defaultConfig</require>
  <extension
      target="org.nuxeo.ecm.platform.ui.web.auth.service.PluggableAuthenticationService"
      point="authenticators">
    <authenticationPlugin name="AUTOMATION_BASIC_AUTH" enabled="true"
        class="org.nuxeo.ecm.platform.ui.web.auth.plugins.BasicAuthenticator">
      <parameters>
        <parameter name="AutoPrompt">true</parameter>
        <parameter name="RealmName">Nuxeo Automation</parameter>
        <parameter name="ExcludeBAHeader_Token">X-Authentication-Token</parameter>
        <parameter name="ExcludeBAHeader_Token">X-No-Basic-Header</parameter>
      </parameters>
    </authenticationPlugin>
  </extension>

  <extension
      target="org.nuxeo.ecm.platform.ui.web.auth.service.PluggableAuthenticationService"
      point="specificChains">

    <specificAuthenticationChain name="Automation" handlePrompt="false">
        <urlPatterns>
            <url>(.*)/automation.*</url>
        </urlPatterns>

        <replacementChain>
            <plugin>AUTOMATION_BASIC_AUTH</plugin>
        </replacementChain>
    </specificAuthenticationChain>

  </extension>

</component>

Documentation